Engage Platform Release
Incident Report for ScribbleLive
Resolved
This incident has been resolved.
Posted Jun 12, 2019 - 23:13 EDT
Monitoring
Due to unexpected stability and performance issues related to yesterday’s release, we have reverted back to the June 10th build of the Engage platform. We appreciate your patience as we work to deliver the best possible version of Engage to our users. All areas of the Engage platform are now fully operational. We will continue to review the details of yesterday's release and will provide further updates as soon as possible.
Posted Jun 11, 2019 - 23:05 EDT
This incident affected: Client Area and Client Area : Statistics & Analytics.